TrollStore 2 saab pärast esialgset väljalaskmist hulga väiksemaid veaparandusi

Proovige Meie Instrumenti Probleemide Kõrvaldamiseks





Trollipood 2 ametlikult vabastati esmaspäeval , tuues rakenduse püsiallkirjastamise võimalused tervele hulgale uuematele seadmetele, milles töötab iOS ja iPadOS 15.5–16.6.1 ja 17.0. Eelmise põlvkonna TrollStore toetas juba iOS-i ja iPadOS-i 14.0–15.4.1, seega on tänane värskendus värskendav, mis annab rohkematele kasutajatele juurdepääsu võimsatele funktsioonidele, mida Apple neil ei soovi.



  TrollStore'i bännerpilt.

Vaatamata väljakutsetele, millega me ikka veel silmitsi seisame mõne ülalmainitud uuema püsivara installimeetodite leidmisel, ei ole see peatanud projekti juhtivat arendajat Lars Fröderit ( @opa334dev ).

Selle asemel, et teha üks postitus, mis tähistab iga väiksemat TrollStore 2 värskendust, on iDB otsustanud kasutada kokkuvõtvat lähenemisviisi, et muuta see lihtsamaks. Sellegipoolest kirjeldame allpool kõiki viimaseid värskendusi järjestikuses järjekorras esmaspäeva õhtu seisuga:



TrollStore'i versioon 2.0.1

– Lahendage probleem kahendfailide allkirjastamisel, millel on laadimiskäsud, mida ChOma ei mõista (nt oobPCI sees Dopamiin )
– Parandage äärejuhtum, mis võib põhjustada TrollStoreHelperi krahhi, kui see ei leia koodikataloogi (nagu ülaltoodud juhtumi puhul).

TrollStore'i versioon 2.0.2



– Uuendage iOS 14-s allkirjastamismeetodina ldid, sest ilmselt tutvustati TrollStore'i praegu kasutatavaid CodeSigning API-sid alles iOS 15-s :/, kaks eelmist värskendust olid iOS 14-s nii katki, et te ei saa isegi selle rakenduse abil värskendada. enam süsteemirakendusse installitud püsivusabi, kasutage värskendamiseks meetodit, millega algselt installisite TrollStore'i, nt. GTA Car Trackeri või TrollHelperi pakett, kui jailbreak on, saavad iOS 14 kasutajad, kes on endiselt versioonis 1.x, värskendada selle versiooniga trahvi, vabandame ebamugavuste pärast!

TrollStore'i versioon 2.0.3

– Kasutage kõikides versioonides uuesti ldid-d, kuna rakenduses Security.framework ilmnes manustatud raamistike allkirjastamisega seotud probleem, millele ma ei leidnud lahendust, ldid-ga allkirjastamisel seda probleemi ei esine, seega kasutatakse seda esialgu kuni Leian lahenduse või parema lahenduse



TrollStore'i versioon 2.0.4

– Ilmselt ei tööta ldid-allkirjaga binaarfailid operatsioonisüsteemis iOS 16+, seega kasutame versioonis iOS 16+ uuesti faili Security.framework (ja jah, sellel on endiselt probleem manustatud raamistikega, see parandus on veel pooleli :/ aga vähemalt see ei toimi praegu 14-15)



TrollStore'i versioon 2.0.5

– Lülitage kõik versioonid tagasi versioonile ldid, kuna selle mittetöötamise algpõhjus 15.5+ puhul oli see, et minu GitHubis hostitud ldid-binaarfaili ei allkirjastatud uue CoreTrusti veaga…. Nii et ldid töötab praegu kõigis versioonides ja see peaks nüüd lahendama kõik rakenduste kokkujooksmisprobleemid (veenduge, et värskendate seadetes ldid versioonile v2.1.5-procursus7-new)



Nagu ilmselt võite öelda, on palju edasi-tagasi, kuna Fröder on püüdnud lahendada probleeme, mis hõlmavad suurt hulka iOS-i ja iPadOS-i versioone. Selle põhjuseks on asjaolu, et kuigi üks meetod töötab suurepäraselt uuemate versioonide puhul, ei tundu see vanemate versioonide puhul nii hästi töötavat.

Praeguse seisuga soovitame tungivalt installida uusimale versioonile TrollStore'i versioon 2.0.5, kuna see lahendab nii iOS-i kui ka iPadOS-i uute ja vanade versioonide ebastabiilsused. Veel üks märkus on see, et kui kasutate iOS-i või iPadOS 14, siis ei tohiks te isegi proovida installida ega kasutada versiooni 2.0.1, kuna selle versiooniga on tõsiseid probleeme, mis tingisid mõned täiendavad värskendused.



Niikaua kui kasutate TrollStore 2 uusimat versiooni, saate praegu nautida iOS-i ja iPadOS-i beetaversioonide 14.0–16.6 beetaversioonide 14.0–16.6 rakenduse püsiallkirjastamise võimalusi. CoreTrusti viga mõjutab ka iOS-i ja iPadOS-i 16.6.1 ja 17.0, kuid arendajad pole veel välja mõelnud, kuidas installida TrollStore 2 nendele püsivara versioonidele. See võib tulevikus muutuda.

Püsiallkirjastamise võimaluste abil saate tõhusalt installida rakendusi oma seadmesse püsivalt, väljaspool App Store'i. See on oluline uuendus alates külglaadimine , kuna see ei nõua installitud rakenduse(de) Apple'i arendajakontoga iga seitsme päeva järel uuesti allkirjastamist. Selle asemel saate importida mis tahes .vägivald fail ja see on avakuval ning sekunditega käivitamiseks valmis.

Allpool on õpetused, kuidas TrollStore'i installida, kuid tasub ka märkida, et üles ja Picasso mõlemad on lisanud installimeetodid seadmete jaoks, mis on vastuvõtlikud MacDirtyCow & kfd kasutab ära, kui alltoodud installimeetodid teie jaoks ei tööta:

  • TrollStore'i installimine iOS-i ja iPadOS-i 14.0-15.x-i koos TrollHelperOTA-ga
  • TrollStore'i installimine iOS-i ja iPadOS-i 15.0–15.1.1 jaoks koos TrollInstalleriga
  • Kuidas installida TrollStore jailpurgitud iOS ja iPadOS 14.0–14.8.1 seadmetesse

Pange tähele, et a jailbreak pole TrollStore'i kasutamiseks kohustuslik, kuid kindlasti saate TrollStore'i siiski kasutada, kui juhtute, et jailbreak on. TrollStore projekt on saadaval Fröderi GitHubi lehel kõigile, kes soovivad projekti jälgida.

Kas olete installinud TrollStore 2 uusima versiooni? Andke meile kindlasti teada allpool olevas kommentaaride jaotises.

Top